Support Forums

Automatical deletio…
 
Notifications
Clear all

Automatical deletion from cloudpanel of dynamic distribution groups

8 Posts
2 Users
0 Likes
56 Views
0
Topic starter

Dear KnowMoreIT-Team,

 

we are currently facing a strange issue where dynamical distributiongroups (created via CloudPanel) are getting automatically removed from CloudPanel after a half day or so.

In Exchange these Dynamical distribution groups are still existing.

CloudPanel Version: VERSION: 3.2.1007.0 

Exchange: Tested with Exchange 2016 and Exchange 2019

CloudPanel Settings for CloudPanel Service -> Database (I guess this is related to):

Both intervals set to 240 minutes (reduced from default for testing the automatical “deletion” of the dyn.dist.grps.).

Normal distribution groups are not affacted here, “just” dynamical ones.

Is there already something known related this?

 

Kind regards,

Kevin Kleinjung

E&W Consulting GmbH & Co. KG

3 Answers
0

There is a process in the service to compare groups in the database to groups in AD. Can you search the CloudPanel Service logs for the following string: “Unable to find distribution group”

It searches AD for the group by the ObjectGUID, and if it doesn’t find it, it will remove it from the database.

0
Topic starter

Hi Jacob,

yes such entries are present!

0
Topic starter

Hi Jacob,

additional:

In fact the GUIDs are matching but the detection that the distribution group could not be found is may be faulty right?

 Here a screenshot of the log and an example Get-ADObject Query for proof that the object is existing.

 

Kind regards,

Kevin

Jacob Dixon 2024-02-06 08:15

@kevinkleinjung it very well could be. I will check into this and report back

KevinKleinjung Topic starter 2024-02-06 08:16

Thank you Jacob!

KevinKleinjung Topic starter 2024-02-08 02:14

Hi Jacob,

were you already able to find something that could may be the cause of this?

If you need more Logfiles/tests from my side please don’t hestiate to ask 🙂

 

Kind regards,

Kevin

 

Jacob Dixon 2024-02-08 07:35

@kevinkleinjung Yes, we found the issue and corrected it. I have a new build, but we haven’t put together the release notes yet because it is so new. The problem was we were checking dynamic groups but using a looking in AD that didn’t support searching for dynamic groups, so they would never find a match.

KevinKleinjung Topic starter 2024-02-08 07:37

Hi Jacob,

glad to hear! Great reaction as always. Many thanks. Will keep my eyes open for the patch 🙂

 

Kind regards,

Kevin

Share: